IPi Mocap Studio Changelog

From iPiSoft Wiki
Jump to: navigation, search

Here you can find history of recent versions of iPi Mocap Studio.

iPi Mocap Studio has built-in auto update functionality. Auto update feature is configured so that checks for update are made once per day. It helps to reduce the start time of the application. If you want to update ASAP — you can use the Help > Check for Update menu item.

Note that both these features require Internet connection. Alternatively (in case of troubles with auto update), you can download and run the updated installation program from our website.


Contents

ver. 2.6.1.163

Version 2.6.1.163
Mar 11, 2014
Download-24.png  Download

 N E W    F E A T U R E S:

  • Displaying the time of the current frame.


 B U G    F I X E S:

  • Correct handling of FPS when exporting/opening FBX animations.


ver. 2.6.0.162

Version 2.6.0.162
Feb 21, 2014
Download-24.png  Download

 B U G    F I X E S:

  • Error when opening animation.
  • Help window does not fit to a page width.


ver. 2.6.0.161

Version 2.6.0.161
Feb 19, 2014
Download-24.png  Download

 N E W    F E A T U R E S:

  • iPi Biomech Add-on released.
This is a tool for in-depth biomechanical analysis of human motions. It includes visualization of tracking data and its export to various formats.
Note that Add-on is not a free update and requires separate license key. 30-days free trial is available. For more information please read Biomechanical Analysis article.
IPi-Biomech-1-1.jpg
  • Reliable saving of project files ensures that project file will not be corrupted even if system crash occurs during saving operation
  • Increased performance of hands / fingers keyframing
  • User Guides added to Help menu:
    • Multiple Actors
    • Motion Controllers
    • Hand keyframing
    • Multiple GPUs
    • Batch Processing
    • Biomechanical Analysis
  • Minimize button added to Batch Running dialog window


 B U G    F I X E S:

  • Color picker tool did not work when Move or IK tools were selected
  • Program crash in case when Jitter removal runs with View > Pose Mismatch option checked
  • Program crash during calibration with Auto-detect initial camera positions enabled under certain conditions


ver. 2.5.1.159

Version 2.5.1.159
Nov 6, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Manual position adjustment of gyro sensors using Move tool

 B U G    F I X E S:

  • Not enough precision of Euler Angles near Gimbal Locks during export to BVH, FBX and SMD. This bug was introduced in the previous version.


ver. 2.5.0.158

Version 2.5.0.158
Oct 11, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Experimental support for triple depth sensor configuration. For more information please read Getting Started article. This functionality is available in Standard edition only. In other editions you can try it but export will be disabled.
  • List of options for spine flexibility is extended:
New ValueAppropriate Old Value
Stiff Lower SpineStiff Lower Spine
Flexible Lower SpineFlexible Lower Spine (male actor)
Very Flexible Lower Spine (e.g. dancer)Flexible Lower Spine (female actor)

The last value is useful for slow plastic motions.

  • Batch processing now supports the animation export (as a separate step).
  • Usability improvements of 3D tools:
    • Character skin is transparent for clicks on the elements of the Move and IK tools.
    • Hit area is increased for the elements of the Move and IK tools.
    • Highlighting active items under the mouse pointer in 3D viewport.
  • Continuity of Euler angles is maintained in exported BVH, FBX and SMD files as described here.
  • Indication of unsaved changes in the current project. Request to save changes before operations leading to closing the project (e.g. exit from the program).
  • The Close Project menu item.

 B U G    F I X E S:


ver. 2.4.1.156

Version 2.4.1.156
Sep 7, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

 B U G    F I X E S:

  • Fixed bug with support of multiple monitors.
  • Fixed bug with incorrect clavicle position for 3D Max Biped and some other rigs (the rigs with default pose different from T-pose were affected).
  • Fixed bug with mouse clicks in 3D view port after window resizing and/or splitter movements.


ver. 2.4.0.154

Version 2.4.0.154
Aug 7, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Multiple actors support (Standard edition only).
    See this article for details.
  • Multiple video cards support (Standard edition only).
    See this article for details.
  • Batch processing (Standard edition only).
    See this article for details.
  • Removed 2GB file size limitation for video export.
  • Official support for tracking with 8 color cameras (Standard edition only). Support for 8 cameras is especially actual for multiple persons tracking.
    Recent releases already support 8 PS Eyes, but this feature is marked as "experimental" (there is a corresponding warning). In this release we just remove this warning. Some of our customers successfully track with 8 cameras for a long period of time, so we may consider it as stable now.
  • Minor improvements of tracking accuracy.
  • New Jitter Removal algorithm now preserves more details of the motion. Default value for Jitter Removal changed to 2.
  • Inverted mouse wheel behavior in viewport.
    A motivation for this change was to make the behavior consistent with multi-touch "pinch to zoom" gesture, as well as with the majority of other apps. In the future releases this may become a user-defined setting. Sorry for inconvenience.
  • Minor improvements in look-and-feel of Jitter Removal Options dialog.
  • Tabs area width is restored from the previous launch of application (same as with window size).
New features of Standard edition can be tried in other editions. When using these features, projects are saved in the trial format prohibiting the export of animations.

 B U G    F I X E S:

  • Fixed video opening error when project and video are located on different drives.


ver. 2.3.2.150

Version 2.3.2.150
Jun 10, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Audio playback support.
    Version 2.2.0.24 or later of iPi Recorder is required for audio recording.
  • MRU lists for poses in the context menu for a hand key frame.
    Recently saved/loaded hand poses are automatically put to the context menu for hand key frames of the corresponding hand, just below the standard poses. So to apply one of those poses you do not need to click Edit > Load Pose from File, then Ctrl + V. Just open context menu for a key frame and choose a pose.

 B U G    F I X E S:

  • Fixed error when clicking on markers during the calibration process.


ver. 2.3.1.149

Version 2.3.1.149
Apr 06, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Support for the head tracking with a motion controller
  • Improvements in New Project Wizard:
    • ability to load actor parameters from file
    • auto loading of scene and actor parameters from the directory containing a video
  • Built-in motion transfer profiles updated for better fingers support
  • Improved Refit Pose accuracy

 B U G    F I X E S:

  • Fixed several issues when running with non-default DPI settings (e.g. 125% fonts)


ver. 2.3.0.148

Version 2.3.0.148
Mar 08, 2013
Download-24.png  Download

 B U G    F I X E S:

  • Error during opening of iPiMocap projects saved by versions before 2.1.2.141.


ver. 2.3.0.147

Version 2.3.0.147
Feb 26, 2013
Download-24.png  Download

 B U G    F I X E S:

  • Error during export of animation in some formats (Object reference not set to an instance of an object.)


ver. 2.3.0.146

Version 2.3.0.146
Feb 25, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Hand keyframing (poses for fingers). See Getting Started guide.
  • Changes in timeline:
    • Multi-colored tracks and items.
    • New context menu, including items for toggling the visibility of particular tracks.
    • Zoom and Scroll to Current Frame buttons — moved to the right side above the timeline.
    • Strobe settings moved to the context menu of the strobe marker, and the strobe track made invisible by default.
  • Tracking option for spine:
    • Stiff Lower Spine (like version 1.x — default for new projects)
    • Flexible Lower Spine (previous default behaviour of version 2.x)
  • Renamed tracking option for shoulders (now with drop-down list instead of checkbox):
    • Shoulder position calculated from arm position
    • Shoulder position tracked from video (useful for some movements like boxing or dancing)
  • Improved calibration for dual depth sensors:
    • Removed 90/180 degrees setting (no longer needed — auto-detected in new version).
    • Better accuracy of the ground detection.
  • Implemented auto-restore of last size and state (normal/maximized) of the main window at application startup.
  • Undo also restores previous bone selection.
  • Initially active tab for calibration projects is now set to Calibration; for action projects to Tracking.

 B U G    F I X E S:

  • When using the IK tool, bone selection using the Select drop-down menu or skeleton navigation keys was not working properly.
  • iPi Mocap Studio crashed when UAC screen was shown during tracking.
  • Orbit around the selected bone of imported target character (Ctrl + right button drag) was not working properly.


ver. 2.2.1.145

Version 2.2.1.145
Jan 18, 2013
Download-24.png  Download

 N E W    F E A T U R E S:

  • Tracking improvements:
    • Much improved shoulder tracking.
    • Improved spine tracking.
    • Improved head tracking for RGB cameras (with support for head rotations around Y axis).
      • Note that head tracking significantly slows down tracking speed. Head tracking is optional, you can turn it off in tracking options.
    • New "Refine" functionality (useful for cleanup).
  • UI improvements:
    • Timeline zoom and scrolling.
    • Color picker tools for actor appearance items.
    • Additional capabilities in 3D Viewport navigation:
      • Left mouse button drag — move view (the same as middle mouse button drag).
      • Shift + right mouse button drag — rotate view around viewpoint.
      • Ctrl + right mouse button drag — orbit view around selected bone (extremely helpful in case of fingers position editing).
Refine Pass
Color Picker Tools
Time Line Zoom


ver. 2.2.0.144

Version 2.2.0.144
Dec 13, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Support for hand/prop tracking using data recorded from motion controllers. See Getting Started guide.
    Warning. Projects with motion controller data cannot be open by previous versions of iPi Mocap Studio.
  • Long-awaited Undo/Redo for manual editing and for automatic processing. Standard shortcuts Ctrl+Z, Ctrl+Y work.
  • Additional commands for working with pose (under menu Edit):
    • Copy pose of selected bone's children (and all descendants) only. Available only as menu item. Useful for copying hand poses (without rotation of hand's joint itself).
    • Paste pose to all frames within ROI (Ctrl+Shift+V).
    • Save pose to a file from the Clipboard (Ctrl+P). Using this and the following command, you can make a sort of a pose library.
    • Load pose from a file to the Clipboard (Ctrl+L).
  • Navigating through skeleton using the keyboard:
    • Go to parent bone ([)
    • Go to child bone (]). Moves selection to a first child. If there are no children, moves to a next sibling bone (or parent's sibling, etc). Makes a full walk around the skeleton.
    • Cycle through bones of the same level of hierarchy (Shift+[, Shift+])
  • Improved skeleton visualization. Joint size and bone thickness are proportional to bone length. Now fingers are much easier to edit.
  • Improved calibration accuracy for dual depth sensor configuration.
  • Improved accuracy of feet tracking with PS Eyes.
  • Improved actor's model.
  • Menu item Help > Keyboard Shortcuts shows all keyboard shortcuts in one place. The same information is available as a wiki page.

 B U G    F I X E S:

  • Opening video causes Device does not support multi-level texture width and height values that are not powers of 2. error with some video cards.
  • Running calibration with ROI less than 8 frames crashes the app.


ver. 2.1.3.143

Version 2.1.3.143
Nov 23, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • New items in Edit menu for coping parts of body position:
    • Copy Pose of Selected Bone — copies rotations for selected bone to Clipboard. For paste use Paste Pose menu item.
    • Copy Pose of Selected Bone with Children — copies rotations for selected bone and all its children to Clipboard. For paste use Paste Pose menu item.
  • If video from depth sensors like MS Kinect or ASUS Xtion has RGB channel then now you can colorize 3D point cloud using data from RGB camera. To turn on this feature please use View > Color Point Cloud with RGB Data menu item.
  • Added iPiMocap: namespace only for MotionBuilder-optimized FBX output (Export > For MotionBuilder (FBX, BVH) menu item).
  • Improved look and feel of Open and Save file dialogs for modern operating systems like Windows 7.
Color Point Cloud with RGB Data

 B U G    F I X E S:

  • Incorrect import of characters with 3D MAX Biped bone naming conventions (in particular, CryEngine default characters).
  • Export as DMX produces incorrect DMX file if in windows localization setting coma is selected as decimal symbol.


ver. 2.1.2.142

Version 2.1.2.142
Nov 08, 2012
Download-24.png  Download

 B U G    F I X E S:

  • Importing of some target characters doesn't work.
  • Version is not visible in About box.


ver. 2.1.2.141

Version 2.1.2.141
Nov 07, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Added support for Valve DMX format export/import for use with Source Film Maker.
  • Fixed the issue with bone naming in FBX (removed "iPi:" prefix).
  • Improved point cloud visualization for depth data from Kinect and Xtion sensors.
  • New default background color in 3D viewport.
  • Size of application files is significantly reduced (3x times) which saves disk space and improves speed of automatic updates.
  • Added ability to activate license key for all OS users (to know how please contact our support).
  • Minor UI improvements and bug fixes.


ver. 2.1.1.140

Version 2.1.1.140
Oct 13, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Improved spine tracking. Removed the problem with unnatural spine position when stooping down
  • Improved jitter removal for torso and head
  • Precise bone selection using dropdown menu of Select toolbar button
  • MRU list for projects, available in menu and toolbar
  • Nice Check for update window with link to changelog
  • Showing release notes at first launch of new version
  • Small UI improvements:
    • Current frame number made editable for quick goto
    • Merged Play and Pause buttons
    • Highlighting selected bones when editing motion transfer profile
    • Alphabetical sorting and removing of items in MRU lists
    • Export animation XXX menu items moved to submenu, Export animation XXX buttons merged to single dropdown button
Select bone
MRU project list
Export animation button


ver. 2.1.0.139

Version 2.1.0.139
Sep 30, 2012
Download-24.png  Download
UI changes

 N E W    F E A T U R E S:

  • Head tracking. Enabled by the Enable head tracking checkbox on the Tracking tab.
Note. This version does not track face orientation, that is head rotation around Y axis.
  • Switched places of Track Forward and Track Backward buttons. The new placement is more intuitive, but may cause confusion for existing users.
  • Improvements in Jitter Removal.
  • Simplified rules for auto-adjusting the Region of Interest. Now it's touched only if the tracking starts when the current position is outside the ROI.
  • More compact project files.
Note. Projects saved by this version can not be opened by the previous releases.
  • Bundled user guides are displayed within the new built-in viewer.

 B U G    F I X E S:

  • Error when running Jitter Removal while current position is outside of the Region of Interest.
  • Error on opening project in certain circumstances.
  • Installation program won't run on Windows XP x64.

ver. 2.0.1.138

Version 2.0.1.138
Aug 04, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Refines in actor model including skeleton proportions.
Note. Existing projects should be re-tracked with new model to take advantages of new version.
  • Alignment of color video to depth point cloud for single and dual Kinect/Xtion projects. This alignment is based on internal calibration data from depth sensor and should work fine for various depth sensors.
Note. To turn off this alignment one can use View > Align Color Video to Depth menu item.
  • Coloring of depth data in iPi Mocap Studio now is like coloring in iPi Recorder.
  • For single and dual Kinect/Xtion projects background is hidden by default if color video is available.


ver. 2.0.0.137

Version 2.0.0.137
Jul 19, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Support for JPEG encoded Bayer tracks in video. Update of iPi Recorder with support for JPEG compression for PS Eyes will be published within a couple of days.
  • Improvements in FBX import concerning character skinning.

 B U G    F I X E S:

  • Fixed error in clavicle retargeting.
  • Fixed issue in installer with .NET Framework installation on Windows Vista and later.


ver. 2.0.0.135

Version 2.0.0.135
Jul 03, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Experimental support for 7-8 color cameras. Auto detection of initial camera positions is not currently working well for these configurations, so it is disabled. This feature is discussed in [1].
  • Improved unexpected errors handling.

 B U G    F I X E S:

  • Fixed error in activation code. This issue is discussed in [2] and [3].


ver. 2.0.0.134

Version 2.0.0.134
Jun 30, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Support for any order of Euler angles in FBX export. This is especially useful for LightWave users.
  • Unexpected error dialog. If an unexpected error occurs in the application, this dialog appears just before the application is terminated. It presents you a debug information. If you provide us with this information when reporting an error, this could greatly help us in investigating your issue.

 B U G    F I X E S:

  • Decreased memory footprint during calibration (specifically, marker detection).


ver. 2.0.0.133

Version 2.0.0.133
Jun 17, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

 B U G    F I X E S:

  • Fixed rounding error causing incorrect value of frames per second. This issue is discussed in [4].
  • Fixed incorrect background processing. This issue is discussed in [5].
  • Fixed application failures when returning from logon screen and standby mode. This issue was primarily discussed by email. Partial discussion is in [6].
  • Fixed ignoring the Export T-pose in first frame option and Recenter coordinate system on character in first frame checkboxes. This issue is discussed in [7].


ver. 2.0.0.132

Version 2.0.0.132
Jun 13, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • List of most recently used target characters along with motion transfer profiles.

 B U G    F I X E S:

  • Fixed several issues in exporting/importing animations for 3D MAX and MotionBuilder.


ver. 2.0.0.131

Version 2.0.0.131
Jun 07, 2012
Download-24.png  Download

 B U G    F I X E S:

  • Fixed coordinate system bug in tracking the left hand.
  • Fixed startup error occurring on some WinXP/Vista computers. This issue is discussed in [8].


ver. 2.0.0.130

Version 2.0.0.130
Jun 02, 2012
Download-24.png  Download

 N E W    F E A T U R E S:

  • Different menu item and toolbar button for creating new project (File > New project… and New respectively).
  • File > Open is renamed to File > Open project… and now opens only project files.
  • File > Import animation menu item is renamed to File > Open animation…
  • Now visibility of tabs, toolbar buttons and menu items depends on project type.

 B U G    F I X E S:

  • Application installer is slightly updated (some users have experienced troubles with previous one).
  • Bug fix in behavior of Scene Scale slider for multi-camera calibration projects.


ver. 2.0.0.129

Version 2.0.0.129
Jun 01, 2012
Download-24.png  Download

First public release of iPi Mocap Studio 2.

If you're user of iPi Studio 1.x then please visit Migration from v1.x to v2.0 article.

 N E W    F E A T U R E S:

  • New project file format, incompatible with old one. The new format has important changes required for support of multiple actor capture and props capture in future versions.
  • New character model with optimizations for female characters.
  • New skeleton.
  • New video format (.iPiVideo). Old videos can be converted to new format using iPi Recorder#Converter.
  • New project wizard.
  • Improved foot tracking.
  • Improved shoulder tracking.
Personal tools