User Guide for Single Depth Sensor Configuration (printable version)

From iPiSoft Wiki
Jump to: navigation, search

For the impatient:


Contents

System Requirements

iPi Recorder

  • Computer (desktop or laptop):
    • CPU: x86 compatible (Intel Pentium 4 or higher, AMD Athlon or higher), dual- or quad- core is preferable
    • Operating system: Windows 8, 7, XP SP3, Vista (x86 or x64)
  • Microsoft Kinect sensor, or ASUS Xtion Live sensor, or PrimeSense Carmine 1.08 sensor
  • Optional: active USB 2.0 extension cables
  • Optional: Kinect Adjustable Tripod Stands
  • Minimum required space: 3m by 3m (10 by 10 feet)

iPi Mocap Studio

  • Computer (desktop or laptop):
    • CPU: x86 compatible (Intel Pentium 4 or higher, AMD Athlon or higher), dual- or quad- core is preferable
    • Operating system: Windows 8, 7, XP SP3, Vista (x86 or x64)
    • Video card: Direct3D 10-capable (Shader Model 4.0) gaming-class graphics card
GPUz example.gif

Software Installation

iPi Recorder

Before installation:

  • unplug all cameras from computer


Download and run the setup package of the latest version of iPi Recorder. You will be presented with the following dialog.

IPi Recorder 2.0 Setup.png

  1. Select needed components
  2. Read and accept the license agreement by checking appropriate checkbox
  3. Press the Install button to begin installation
Note. Most of the components require administrative privileges because they install device drivers or write to Program Files and other system folders. On Windows Vista/7 you will be presented with UAC prompts when appropriate during installation. If you plan to use iPi Recorder under user which has no administrative rights, you can pre-install other components separately using administrator's account.
Important!
  1. You can plug only one MS Kinect / ASUS Xtion / PrimeSense Carmine sensor to one USB controller. 1 USB controller bandwidth is not enough to record from 2 sensors.
  2. You can plug not more than 2 Sony PS Eye cameras to one USB controller, otherwise you will not be able to capture at 60 fps with 640 x 480 resolution.
For more info see USB controllers.


Upon installation is complete, iPi Recorder will launch automatically. Continue with user's guide to get a knowledge of using the software.

Components

If some of the components is already installed, it has no checkbox and is marked with ALREADY INSTALLED label. You should not install all optional components in advance, without necessity. All of them can be installed separately at later time. Components descriptions below contain corresponding download links.

  • iPi Recorder 2.x.x.x. This is required component and cannot be unchecked.
    iPi Recorder itself.

iPi Mocap Studio

Before installation:

  • Ensure your video card supports DirectX 10. Otherwise, iPi Mocap Studio will not run on your system.

Download and run the latest setup package of iPi Mocap Studio. You will be presented with the following dialog:

IPi Mocap Studio 2.0 Setup.png

  1. Read and accept the license agreement by checking corresponding checkbox.
  2. Press the Install button to begin installation.

Upon installation is complete, iPi Mocap Studio will launch automatically.

All components are required for installation. Please note that the installation of Microsoft .NET Framework 3.5 SP1 requires an Internet connection. If needed, you can download offline installer for Microsoft .NET separately, and run it before iPi Mocap Studio setup. Other components are included with iPi Mocap Studio setup.

As a result of installation, iPi Studio will be executed. You will be prompted to enter your license key or start 30-days free trial period:
Welcome to ipistudio dlg.png


For more info about license protection see License.

Recording Video from Depth Sensor

Finally, after all these preparations completed, you are ready for performance.

Environment

For a single or dual depth sensor configuration, you need a minimum of 10 feet by 10 feet space (3 meters by 3 meters). At smaller space, actor simply won’t fit into view of cameras.

It is convenient to put MS Kinect Sensor on a chair or a table. The picture below will help you to understand possible capture area and required space:

Click to enlarge
Click to enlarge
Side view
Top view

Actor Clothing

Current version uses only depth information to track motions. So clothes requirements are:

  • no restrictions on clothes colors (just avoid shiny fabrics)
  • please use slim clothes to reduce noise in resulted animation

Recording Process

Please record a video using iPi Recorder application. It supports recording with Sony PlayStation Eye cameras, depth sensors (Kinect) and DirectShow-compatible webcams (USB and FireWire).

iPi Recorder is a stand-alone application and does not require a powerful video card. You may choose to install it on a notebook PC for portability. Since it is free, you can install it on as many computers as you need.

Please run iPi Recorder and complete setup and background recording steps following the instructions:

iPi Recorder Setup

Recording Actor's Performance

After completing Setup and Background recording steps, press “Record” button to begin video recording.

As soon as recorder starts, go to the capture area and stand in a T-pose:
Click to enlarge

After that you can act desired motions. If you make several takes of one actor, you do not need to record T-pose again.

To stop recording, press “Stop” button.

Performance Tips

Recommended layout of an action video

  • Enter the actor.
  • Strike a T-pose.
  • Action
T-pose.png Action.png

T-pose

It is preferable to have actor strike a “T-pose” before the actual action. The software will need T-pose for building actor appearance model during tracking. If you make several takes of one actor you do not need to re-record T-pose before each take.

When using the depth sensors, it is recommended to face the palms down, as it corresponds to the default orientation of the model's hand bones. When using color cameras, it is recommended to face the palms forward, as it helps the software in determining the right color for the model's hands.

Takes

Take is a concept originating from cinematography. In a nutshell, take is a single continuous recorded performance.

Usually it is a good idea to record multiple takes of the same motion, because a lot of things can go wrong for purely artistic reasons.

Iterations

A common problem with motion capture is “clipping” in resulting 3D character animation. For example, arms entering the body of animated computer-generated character. Many CG characters have various items and attachments like a bullet-proof vest, a fantasy armor or a helmet. It can be easy for an actor to forget about the shape of the CG model.

For this reason, you may need to schedule more than one motion capture session for the same motions. Recommended approach is:

  • Record the videos
  • Process the videos in iPiStudio
  • Import your target character into iPiStudio and review the resulting animation
  • Give feedback to the actor
  • Schedule another motion capture session if needed

Ian Chisholm's hints on motion capture

Ian Chisholm is a machinima director and actor and the creator of critically acclaimed Clear Skies machinima series. Below are some hints from his motion capture guide based on his experience with motion capture for Clear Skies III.

Three handy hints for acting out mocap:

  1. Don’t weave and bob around like you’re in a normal conversation – it looks terrible when finally onscreen. You need to be fairly (but not completely) static when acting.
  1. If you are recording several lines in one go, make sure you have lead in and lead out between each one, i.e. stand still! Otherwise, the motions blend into each other and it’s hard to pick a start and end point for each take.
  1. Stand a bit like a gorilla – have your arms out from your sides:
    Gorilla.jpg
    Well, obviously not quite that much. But anyway, if you don’t, you’ll find the arms clip slightly into the models and they look daft.

If you have a lot of capture to do, you need to strike a balance between short and long recordings. Aim for 30 seconds to 2 minutes. Too long is a pain to work on later due to the fiddlyness of setting up takes, and too short means you are forever setting up T-poses.

Takes

Because motion capture is not a perfect art, and neither is acting, it’s best to perform multiple takes. I found that three was the best amount for most motion capture. Take less if it’s a basic move, take more if it’s complex and needs to be more accurate. It will make life easier for you in the processing stage if you signal the break between takes – I did this by reaching out one arm and holding up fingers to show which take it was.

Naming conventions

As it’s the same actor looking exactly the same each and every time, and there is no sound, and the capture is in lowres 320*200, you really need to name the files very clearly so that you later know which act, scene, character, and line(s) the capture is for.

My naming convention was based on act, scene, character, page number of the scene, line number, and take number. You end up with something unpleasant to read like A3S1_JR_P2_L41_t3 but it’s essential when you’ve got 1500 actions to record.

Processing Video from Depth Sensor

  • Run iPi Mocap Studio
  • Press Ctrl+N or push New button on toolbar to create new project
  • Choose recorded *.iPiVideo file
  • After video opened, background will be calculated automatically and position of camera will be detected based on floor plane.
  • Make sure, that floor is detected correctly:
    1. Right mouse button down on 3d view port area
    2. Move mouse, as a result 3d scene will be rotated
    3. Right mouse button up
    4. Visually control that 3d points from floor are located on ground plane which is marked by squared grid
KSensor-process-step2.png
Note that you always can get back to the camera point of view by pressing 1 key on keyboard or pushing “Camera 1” button on toolbar
  • Save created project by pressing Ctrl+S or pushing button Save on toolbar
  • Position timeline slider to the frame where actor is in T-pose
  • Adjust actor height using appropriate slider on tab Actor
  • Select Move tool on toolbar.
  • Move actor model to left or right to match roughly actor silhouette on video. Note that actor model can look smaller due to its position along axis of view. Don’t pay attention to it on this step.
KSensor-process-step3.png
  • Switch to Tracking tab and push Refit pose button.
  • As a result model should be matched with actor image from video. If it does not happen then delete result using item Edit > Delete pose from main menu and repeat above actions.
KSensor-process-step4.png
  • Using the slider right to the button Show Skin in toolbar, make sure that morph of model corresponds to the actor image. If no, than adjust chest/bust/waist/hips/belly morph using appropriate sliders from Actor tab.
KSensor-process-step4a.png
  • Set the beginning of Region-of-Interest (ROI) to the current frame with T-pose by pressing I key on keyboard or by double-clicking on the left edge of ROI bar under timeline.
  • Switch to Tracking tab, change tracking options (Head tracking, Shoulders and Spine) if required.
  • To start tracking just push Track Forward button.
Click to enlarge
  • Wait and watch...

Clean-up

Once initial tracking is performed on all (or part) of your video, you can begin cleaning out tracking errors (if any). Post-processing should be applied after clean-up.

Cleaning up tracking gaps

Tracking errors usually happen in a few specific video frames and propagate to multiple subsequent frames, resulting in tracking gaps. Examples of problematic frames:

  • Occlusion (like one hand not visible in any of the cameras)
  • Indistinctive pose (like hands folded on chest).
  • Very fast motion with motion blur.

To clean up a sequence of incorrect frames (a tracking gap), you should use backward tracking:

  1. Go toward the last frame of tracking gap, to a frame where actor pose is distinctive (no occlusion, no motion blur etc.).
  2. If necessary, use Rotate, Move and IK (Inverse Kinematics) tools to edit character pose to match actor pose on video.
  3. Turn off Trajectory Filtering (set it to zero) so that it does not interfere with your editing.
  4. Click Refit Pose button to get a better fit of character pose.
  5. Click Track Backward button.
  6. Stop backward tracking as soon as it comes close to the nearest good frame.
  7. If necessary, go back to remaining parts of tracking gap and use forward and backward tracking to clean them up.

Cleaning up individual frames

To clean up individual frames you should use a combination of editing tools (Rotate, Move and Inverse Kinematics) and Refit Pose button.

Note: after Refit Pose operation iPi Mocap Studio automatically applies Trajectory Filtering to produce a smooth transition between frames. As the result, pose in current frame is affected by nearby frames. This may look confusing. If you want to see exact result of Refit Pose operation in current frame you should turn off Trajectory Filtering (set it to zero), but do not forget to change it back to suitable value later.

Tracking errors that cannot be cleaned up using iPi Studio

Not all tracking errors can be cleaned up in iPi Mocap Studio using automatic tracking and Refit Pose button.

  • Frames immediately affected by occlusion sometimes cannot be corrected. Recommended workarounds:
    • Manually edit problematic poses (not using Refit Pose button).
    • Record a new video of the motion and try to minimize occlusion.
    • Record a new video of the motion using more cameras.
  • Frames immediately affected by motion blur sometimes cannot be corrected. Recommended workarounds:
    • Manually edit problematic poses (not using Refit Pose button).
    • Edit problematic poses in some external animation editor.
    • Record a new video of the motion using higher framerate.
  • Frames affected by strong shadows on the floor sometimes cannot be corrected. Typical example is push-ups. This is a limitation of current version of markerless mocap technology. iPi Soft is working to improve tracking in future versions of iPi Mocap Studio.
  • Some other poses can be recognized incorrectly by iPi Mocap Studio. This is a limitation of current version of markerless mocap technology. iPi Soft is working to improve tracking in future versions of iPi Mocap Studio.

Tracking refinement

After the primary tracking and cleanup are complete, you can optionally run the Refine pass (see Refine Forward and Refine Backward buttons). It slightly improves accuracy of pose matching, and can automatically correct minor tracking errors. However, it takes a bit more time than the primary tracking, so it is not recommended for quick-and-dirty tests.

Important. Refine should be applied with the same tracking parameters (e.g. feet tracking, head tracking) as the primary tracking in order not to lose previously tracked data.

Important. Refine should be applied before motion controller data. Also, if you plan to manually edit the animation (not related to automatic cleanup with Refit Pose), then also do this after applying Refine.

In contrast to the primary tracking, this pass does no pose prediction, and bases its computations solely on the current pose in a frame. Essentially, running Refine is equal to automatically applying Refit Pose to a range of frames which were previously tracked.

Post-processing: Jitter Removal

Jitter Removal filter is a powerful post-processing filter. It should be applied after cleaning up tracking gaps and errors.

It is recommended that you always apply Jitter Removal filter before exporting animation.

Jitter Removal filter suppresses unwanted noise and at the same time preserves sharp, dynamic motions. By design, this filter should be applied to relatively large segments of animation (no less than 50 frames).

Range of frames affected by Jitter Removal is controlled by current Region of Interest (ROI).

You can configure Jitter Removal options for specific body parts. Default setting for Jitter Removal “aggressiveness” is 1 (one tick of corresponding slider). Oftentimes, you can get better results by applying a slightly more aggressive Jitter Removal for torso and legs. Alternatively, you may want to use less aggressive Jitter Removal settings for sharp motions like martial arts moves.

Jitter Removal filter makes an internal backup of all data produced by tracking and clean up stages. Therefore, you can re-apply Jitter Removal multiple times. Each subsequent run works off original tracking/clean-up results and overrides previous runs.

Post-processing: Trajectory Filtering

Trajectory Filter is a traditional digital signal filter. Its purpose is to filter out minor noise that remains after Jitter Removal filter.

Trajectory Filter is very fast. It is applied on-the-fly to current Region of Interest (ROI).

Default setting for Trajectory Filter is 1. Higher settings result in multiple passes of Trajectory Filter. It is recommended that you leave it at the default setting.

Trajectory Filter can be useful for “gluing” together multiple segments of animation processed with different Jitter Removal options: change the Region of Interest (ROI) to cover all of your motion (e.g. multiple segments processed with different jitter removal setting); change Trajectory Filtering setting to 0 (zero); then change it back to 1 (or other suitable value).

Export and Motion Transfer

Use File > Export Animation menu item to export all animation frames from within Region of Interest (ROI).

To export animation for specific take, right-click on take and select Export Animation item from pop-up menu.

Default iPi Character Rig

The default skeleton in iPi Mocap Studio is optimized for markerless motion capture. It may or may not be suitable as a skeleton for your character. Default iPi skeleton in T-pose has non-zero rotations for all joints. Please note that default iPi skeleton with zero rotations does not represent a meaningful pose and looks like a random pile of bones.

Default rig
Bone names

By default iPi Mocap Studio exports a T-pose (or a reasonable default pose for custom rig after motion transfer) in the first frame of animation. In case when it is not desired switch off Export T-pose in first frame checkbox.

Motion Transfer and Custom Rigs

iPi Mocap Studio has integrated motion transfer technology. You can import your character into iPi Studio via File > Import Target Character menu item and your motion will be transferred to your character. You may need to assign bone mappings on the Export tab for motion transfer to work correctly. You can save your motion transfer profile to XML file for future use. iPi Mocap Studio has pre-configured motion transfer profiles for many popular rigs (see below). If you export animation to format different from format your target character was imported in, only rig will be exported. If you use the same format for export, skin will be exported as well.

MotionBuilder

Use the Export Animation for MotionBuilder menu item to export your motion in MotionBuilder-friendly BVH format. MotionBuilder-friendly skeleton in T-pose has zero rotations for all joints, with bone names consistent with MotionBuilder conventions. This format may also be convenient for use with other apps like Blender.

3D MAX Biped

Use the Export Animation for 3D MAX menu item to export your motion in 3D MAX-friendly BVH format.

Create a Biped character in 3D MAX (Create > Systems > Biped). Go to Motion tab. Click Motion Capture button and import your BVH file.

Step 1
Step 2
Step 3
Step 4

Our user Cra0kalo created an example Valve Biped rig for use with 3D MAX. It may be useful if you work with Valve Source Engine characters.

Maya

Latest versions of Maya (starting with Maya 2011) have a powerful biped animation subsystem called "HumanIK". Animations exported from iPi Mocap Studio in MotionBuilder-friendly format (the Export Animation for MotionBuilder menu item) should work fine with Maya 2011 and HumanIK. The following video tutorials can be helpful:

For older versions of Maya please see the #Motion Transfer and Custom Rigs section. Recommended format for import/export with older versions of Maya is FBX.

FBX

iPi Mocap Studio supports FBX format for import/export of animations and characters. By default, iPi Mocap Studio exports animations in FBX 6.0 format using FBX SDK 2012. If your target character is in FBX 7.0 or newer format, iPi Mocap Studio will export retargeted animation in FBX 2012 format.

Some applications do not use latest FBX SDK and may have problems importing newer version FBX files. In case of problems, your can use Autodesk's free FBX Converter to convert your animation file to appropriate FBX version.

COLLADA

iPi Mocap Studio supports COLLADA format for import/export of animations and characters. Current version of iPi Mocap Studio exports COLLADA animations as matrices. In case if you encounter incompatibilities with other applications' implementation of COLLADA format, we recommend using Autodesk's free FBX Converter to convert your data between FBX and COLLADA formats. FBX is known to be more universally supported in many 3D graphics packages.

LightWave

Recommended format for importing target characters from LightWave to iPi Studio is FBX. Recommended format for bringing animations from iPi Mocap Studio to LightWave is BVH or FBX.

SoftImage|XSI

Our user Eric Cosky published a tutorial on using iPi Mocap Studio with SoftImage|XSI:

http://www.ipisoft.com/forum/viewtopic.php?f=13&p=9660#p9660

Poser

Export your poser character in T-pose in BVH format (File > Export). Import your Poser character skeleton into iPi Mocap Studio (File > Import Target Character). Your animation will be transferred to your Poser character. Now you can use File > Export Animation to export your animation in BVH format for Poser.

Poser 8 has a bug with incorrect wrists animation import. The bug can be reproduced as follows: export Poser 8 character in T-pose in BVH format; import your character back into Poser 8; note how wrists are twisted unnaturally as the result.

A workaround for wrists bug is to chop off wrists from your Poser 8 skeleton (for instance using BVHacker) before importing Poser 8 target character into iPi Mocap Studio. Missing wrists should not cause any problems during motion transfer in iPi Mocap Studio if your BVH file is edited correctly. Poser will ignore missing wrists when importing resulting motion so the resulting motion will look right in Poser (wrists in default pose as expected).

Step 1
Step 2
Step 3
Step 4

DAZ 3D

The workflow for DAZ 3D is very similar to Poser. Import your DAZ 3D character skeleton into iPi Mocap Studio (File > Import Target Character). Your animation will be transferred to your DAZ 3D character. Now you can use File > Export Animation to export your animation in BVH format for DAZ 3D.

IMPORTANT: You can use DAZ character in COLLADA (.dae) format for preview, but it is strongly recommended that you use DAZ character in BVH format for motion transfer. DAZ3D has a problem with COLLADA (.dae) format: DAZ3D Studio does not export all bones into COLLADA (.dae). In particular, the following bones are not exported: eyeBrow, bodyMorphs. DAZ3D Studio does not use bone names when importing motions; instead, DAZ3D Studio just takes rotations from the list of angles as though it was a flat list with exactly the same positions as in DAZ3D internal skeleton. As the result, when you transfer the motion to a COLLADA character and import it back into DAZ3D, the motion will look wrong. iPi Mocap Studio displays a warning about this. To avoid this problem, import your DAZ target character in BVH format - DAZ3D Studio is known to export characters in BVH format correctly (with all bones).

You can improve accuracy of motion transfer by doing some additional preparation of your DAZ 3D skeleton in BVH format. For DAZ 3D Michael 4.0 and similar characters, you may need to clamp thigh joint rotation to zero to avoid unnatural leg bending. For DAZ 3D Victoria 4.0, you may need to adjust foot joint rotation to change the default “high heels“ foot pose to a more natural foot pose.

Step 1
Step 2
Step 3
Step 4
Step 5

iClone

Current version of iPi Studio can only export animation in iClone-compatible BVH format. The iMotion format is not supported as of yet. That means you will need iClone PRO to be able to import the motion into iClone. Standard and EX versions of iClone do not have BVH Converter and therefore cannot import BVH files.

Workflow for iClone is straightforward. Export your animation using Export Animation for iClone menu item. Go to Animation tab in iClone and launch BVH Converter. Import your BVH file with Default profile, click Convert and save the resulting animation in iMotion format. Now your animation can be applied to iClone characters.

iClone expects an animation sampled at 15 frames per seconds. For other frame rates, you may need to create a custom BVH Converter profile by copying Default profile and editing Frame Rate setting.

BVH Converted in iClone 4 has a bug that causes distortion of legs animation. iPi Mocap Studio exports an iClone-optimized BVH correctly as can be verified by reviewing exported BVH motion in BVHacker or MotionBuilder or other third-party application. No workaround is known. We recommend that you contact iClone developers about this bug as it is out of control of iPi Soft.

Step 1
Step 2
Step 3
Step 4
Step 5

Valve Source Engine SMD

Import .smd file for your Valve Source Engine character into iPi Mocap Studio via File > Import Target Character menu item. Your animation will be transferred to your character. Now you can use File > Export Animation to export your animation in Valve Source Engine SMD format.

Our user Cra0kalo created an example Valve Biped rig for use with 3D MAX. It may be useful if you wish to apply more then one capture through MotionBuilder or edit the custom keyframes in MAX.

Valve Source Filmmaker

DMX

First, you need to import your character (or its skeleton) into iPi Mocap Studio, for motion transfer.

There are currently 3 ways of doing this:

  1. You can import an animation DMX (in default pose) into iPi Mocap Studio. Since it has a skeleton, it should be enough for motion transfer. To create an animation DMX with default pose, you can add your character to your scene in Source Filmmaker and export DMX for corresponding animation node:
    • open Animation Set Editor Tab;
    • click + > Create Animation Set for New Model;
    • choose a model and click Open;
    • export animation for your model, in ASCII DMX format;
      There is a checkbox named Ascii in the top area of the export dialog.
  2. Alternatively, you can just import an SMD file with your character into iPi Mocap Studio. For example, SMD files for all Team Fortress 2 characters can be found in your SDK in a location similar to the following (you need to have Source SDK installed): C:\Program Files (x86)\Steam\steamapps\<your steam name>\sourcesdk_content\tf\modelsrc\player\pyro\parts\smd\pyro_model.smd).
  3. If you created a custom character in Maya, you should be able to export it in DMX model fromat. (Please see Valve documentation on how to do this).

Then you can import your model DMX into iPi Mocap Studio. Current version of iPi Mocap Studio cannot display character skin, but it should display the skeleton. Skeleton should be enough for motion transfer.

To export animation in DMX, you should just use General... export menu item in iPi Mocap Studio and choose DMX from the list of supported formats. You may also want to uncheck Export T-pose in first frame option on the Export tab in iPi Mocap Studio.

Now you can import your animation into Source Filmmaker. There will be some warnings about missing channels for face bones but you can safely ignore them.

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Old way involving Maya

This was used until iPi Mocap Studio got DMX support. And still may be useful in case of any troubles with DMX. Please see the following video tutorial series:

http://www.youtube.com/playlist?list=PLD4409518E1F04270

Blender

iPi Mocap Studio can export animations in Blender-friendly BVH format. For latest versions of Blender, you can use the MotionBuilder-compatible BVH export option. For Blender version 2.59 or older you can use the Blender 2.59 or older export option.

Cinema4D

If you have experience with Cinema4D please help to expand this Wiki by posting Cinema4D import/export tips to Community Tutorials section of our user forum.

Evolver

iPi Mocap Studio supports importing of skinned Evolver characters in COLLADA or FBX format. Import your Evolver character skeleton into iPi Mocap Studio (File > Import Target Character). Your animation will be retargeted to your Evolver character. Now you can use File > Export Animation to export your animation.

Evolver offers several different skeletons for Evolver characters. Here is an example motion transfer profile for Evolver "Gaming" skeleton: evolver_game.profile.xml

Evolver example.jpg

Second Life

Import your Second Life character skeleton into iPi Mocap Studio (File > Import Target Character). Your animation will be transferred to your Second Life character. Now you can use File > Export Animation to export your animation in BVH format for Second Life.

SecondLife documentation contains a link to useful SL avatar files. The ZIP file includes a BVH of the "default pose". Be sure to have that.

See the discussion on our Forum for additional details: http://www.ipisoft.com/forum/viewtopic.php?f=2&p=7845

Massive

Please see our user forum for a discussion of animation import/export for Massive:

http://ipisoft.com/forum/viewtopic.php?f=12&t=3233

IKinema WebAnimate

Please see the following video tutorial on how to use iPi Mocap Studio with IKinema WebAnimate:

http://www.youtube.com/watch?v=a-yJ-O02SLU

Jimmy|Rig Pro

Please see the following video tutorial on how to use iPi Mocap Studio with Jimmy|Rig Pro:

http://www.youtube.com/watch?v=wD1keDh3fCk

Troubleshooting

Installation problems

Potential problem: after installation, iPi Mocap Studio crashes on first start.

Possible cause: very often, this is caused by incompatible video card. Another possible reason is broken .NET Framework installation or broken DirectX installation.

Solution: check system requirements and make sure your operating system and .NET Framework is up to date.

  • You can use GPU-z and CPU-z to detect exact version and features of your video card.
GPUz example.gif
  • Some systems (for example some laptops and older Mac Minis) have both integrated graphics and discrete graphics. You may need to disable integrated graphics when working with iPi Mocap Studio. To do this, please use tools offered by your discrete video card manufacturer (e.g. Nvidia or AMD).

Two Kinects don't work together

Potential problem: two Kinect sensors do not work togethter.

Possible cause: Most probably, both Kinects were plugged into one USB controller. In this case 1 USB controller bandwidth is not enough to handle video from 2 Kinects.

Solution: Each Kinect should be plugged into separate USB controller. Please refer to documentation User_Guide_for_Dual_Kinect_Sensor_Configuration#Software_Installation

How to report bugs and issues

When reporting bugs and issues, please specify the following info:

  • exact version of your operating system;
  • exact model of your video card (you can use GPU-Z to find out the model of your video card);
  • the number and models of your cameras.

You can post your bug reports on our User Forum or send them to iPiSoft tech support email.

How to send a video to iPiSoft tech support

Sending your videos to iPiSoft tech support can be helpful if you experience a problem with iPiSoft's system. iPiSoft promises to use your video only for debugging and not to disclose it to third parties.

To send a video, please upload it to some file sharing server like filefactory.com and send us the link. The other way is using peer-to-peer technology.

If you cannot send a video because of its huge size, consider sending screenshots. Screenshots are less informative then video but still they are helpful for diagnosing various problems with tracking.

Video Materials

Demo video

iPiSoft Motion Capture Workflow from Paul Stapelberg

"Car scene" by JeanDellac

Click to view

Animation by NextGenReport

Personal tools